CISA Warns GENESIS and ICONICS Users: Version 10.97.3 Doesn't Fix All Vulnerabilities
CISA advisory ICSA-26-300-02 covers flaws in Mitsubishi Electric and ICONICS. Version 10.97.3 is not enough; three 2026 flaws need ICONICS Suite 10.98.
Vulnerabilities
CISA warns of four EPICS Base flaws, including possible remote code execution. Update to 7.0.11 and check network access to your control systems.

On October 27, CISA issued an advisory about four vulnerabilities in EPICS Base. The most serious, CVE-2026-114595, can lead to memory corruption, a service crash or, potentially, code execution. Version 7.0.11 fixes all four. There is no confirmation that any of them has been exploited in attacks.
EPICS is used to build control and supervisory systems. In these environments, the software’s availability affects how connected equipment runs. Advisory ICSA-26-300-01 covers EPICS Base 7.0.10 and earlier releases.
CVE-2026-114595 is an integer overflow in the handling of network requests. The software can calculate the wrong size for a memory allocation, and that can corrupt memory. The flaw has a CVSS 3.1 score of 9.8.
The other three issues involve how message lengths and message elements are validated. They can cause out-of-bounds writes or reads, crash the process and, in some cases, disclose information. The advisory alone does not mean that any particular installation has been breached.
Coordinate the following steps with the people responsible for equipment maintenance and operational continuity:
Updates in a control environment need compatibility testing. Restricting network access can reduce exposure while you prepare the rollout, but it does not remove the vulnerable code.
An inventory of control software should also cover community-developed libraries and components. An infrastructure security audit helps assess network access, who is responsible for what and how patches are rolled out in these environments.
Sources: CyberStack, GitHub Advisory Database, JVN
Read more
CISA advisory ICSA-26-300-02 covers flaws in Mitsubishi Electric and ICONICS. Version 10.97.3 is not enough; three 2026 flaws need ICONICS Suite 10.98.
CISA added CVE-2026-110447 in Collabora's built-in CODE server for Nextcloud to its KEV catalog. Admins should update to 26.4.303 now.
PHP has patched two critical flaws, and exploitation attempts are already appearing. Admins should update environments running websites and apps.
A free consultation with one of our experts — no obligation, in full confidence.
Let's talkWe'd like to use Google Analytics cookies to see how many people visit the site and which content is useful. We'll only set them if you agree. You can change your decision at any time via the “Cookie settings” link in the footer. Cookies Policy